summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 12 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 410a359c..857fc097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR([Makefile.am])
AM_INIT_AUTOMAKE([dist-bzip2])
-AM_CONFIG_HEADER([libdrm/config.h])
+AM_CONFIG_HEADER([config.h])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
@@ -188,18 +188,21 @@ fi
AM_CONDITIONAL(HAVE_INTEL, [test "x$INTEL" != "xno"])
+AC_ARG_WITH([kernel-source],
+ [AS_HELP_STRING([--with-kernel-source],
+ [specify path to linux kernel source])],
+ [kernel_source="$with_kernel_source"])
+AC_SUBST(kernel_source)
AC_SUBST(WARN_CFLAGS)
AC_OUTPUT([
Makefile
- libdrm/Makefile
- libdrm/intel/Makefile
- libdrm/intel/libdrm_intel.pc
- libdrm/radeon/Makefile
- libdrm/radeon/libdrm_radeon.pc
- libdrm/nouveau/Makefile
- libdrm/nouveau/libdrm_nouveau.pc
- shared-core/Makefile
+ intel/Makefile
+ intel/libdrm_intel.pc
+ radeon/Makefile
+ radeon/libdrm_radeon.pc
+ nouveau/Makefile
+ nouveau/libdrm_nouveau.pc
tests/Makefile
tests/modeprint/Makefile
tests/modetest/Makefile