summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b1ae60a..48a49e21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,3 +28,10 @@ pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libdrm.pc
EXTRA_DIST = libdrm.pc.in
+
+copy-headers :
+ cp -r $(kernel_source)/usr/include/drm $(top_srcdir)/include
+
+commit-headers : copy-headers
+ git add include
+ git commit -am "Copy headers from kernel $$(GIT_DIR=$(kernel_source)/.git git describe)"