summaryrefslogtreecommitdiff
path: root/tests/modetest/Makefile.am
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2013-02-11 21:36:30 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2013-06-27 10:01:15 +0200
commit28fff480efe376b9783cdb6a4128036a2fb7c47e (patch)
treef651fe92a2b92415a99d4a5e6f51b1aa1d662f4b /tests/modetest/Makefile.am
parent7214db763ab952771b10d8fdf72b902718f35902 (diff)
modetest: Fix warnings
Enable all standard automake warnings except for -Wpointer-arith (as the test pattern generation code uses void pointer arithmetics) and fix them. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'tests/modetest/Makefile.am')
-rw-r--r--tests/modetest/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/modetest/Makefile.am b/tests/modetest/Makefile.am
index 410c6326..6e7ff14f 100644
--- a/tests/modetest/Makefile.am
+++ b/tests/modetest/Makefile.am
@@ -1,4 +1,6 @@
-AM_CFLAGS = \
+AM_CFLAGS = $(filter-out -Wpointer-arith, $(WARN_CFLAGS))
+
+AM_CFLAGS += \
-I$(top_srcdir)/include/drm \
-I$(top_srcdir)/libkms/ \
-I$(top_srcdir)