summaryrefslogtreecommitdiff
path: root/libdrm/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-09-05 10:35:32 +0100
committerEric Anholt <eric@anholt.net>2008-09-10 14:07:18 -0700
commit738e36acbce24df0ccadb499c5cf62ccb74f56df (patch)
tree271da736d94c1ec99cdf7ae1428aa5d804ddce7c /libdrm/intel/Makefile.am
parent09cf0f0213652609d09154ce2859c03cf97ab11e (diff)
Move intel libdrm stuff to libdrm_intel.so
dri_bufmgr.h is replaced by intel_bufmgr.h, and several functions are renamed, though the structures and many functions remain dri_bufmgr_* and dri_bo_*
Diffstat (limited to 'libdrm/intel/Makefile.am')
-rw-r--r--libdrm/intel/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libdrm/intel/Makefile.am b/libdrm/intel/Makefile.am
index 31a8512a..607c4765 100644
--- a/libdrm/intel/Makefile.am
+++ b/libdrm/intel/Makefile.am
@@ -25,11 +25,16 @@
AM_CFLAGS = \
$(WARN_CFLAGS) \
-I$(top_srcdir)/libdrm \
+ -I$(top_srcdir)/libdrm/intel \
-I$(top_srcdir)/shared-core
-noinst_LTLIBRARIES = libdrm_intel.la
+libdrm_intel_la_LTLIBRARIES = libdrm_intel.la
+libdrm_intel_ladir = $(libdir)
+libdrm_intel_la_LDFLAGS = -version-number 1:0:0 -no-undefined
libdrm_intel_la_SOURCES = \
+ intel_bufmgr.c \
+ intel_bufmgr_priv.h \
intel_bufmgr_fake.c \
intel_bufmgr_gem.c \
mm.c \