summaryrefslogtreecommitdiff
path: root/libdrm/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 23:22:26 -0700
committerDave Airlie <airlied@linux.ie>2008-10-17 06:38:57 +1000
commit6df7b0719fe92b718e486c2b87e2f883cfa41efa (patch)
treec0a48d61bf6dd496d2ecaee2adc1eb111f40466e /libdrm/Makefile.am
parent26076bf24a4e720e389d0a3ea616a8350397fdfc (diff)
intel: Protect bufmgr objects with a pthread mutex.
We want to be able to use the bufmgr from multiple threads for GL, and thus we need to protect the internal structures. The pthread-stubs package is used so that programs not linked against pthreads get weak symbols to stubs and don't eat most of the cost.
Diffstat (limited to 'libdrm/Makefile.am')
-rw-r--r--libdrm/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libdrm/Makefile.am b/libdrm/Makefile.am
index 532ca138..8e1c0ee4 100644
--- a/libdrm/Makefile.am
+++ b/libdrm/Makefile.am
@@ -26,8 +26,8 @@ libdrm_la_LDFLAGS = -version-number 2:3:0 -no-undefined
AM_CFLAGS = -I$(top_srcdir)/shared-core
libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c \
- xf86drmMode.c
-libdrm_la_LIBADD = intel/libdrm_intel.la
+ xf86drmMode.c libdrm_lists.h
+libdrm_la_LIBADD = intel/libdrm_intel.la @PTHREADSTUBS_LIBS@
libdrmincludedir = ${includedir}
libdrminclude_HEADERS = xf86drm.h xf86drmMode.h