summaryrefslogtreecommitdiff
path: root/libdrm/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 23:22:26 -0700
committerEric Anholt <eric@anholt.net>2008-10-09 12:57:09 -0700
commit3169d9639bd002b43e4064cea32e0d262076c1e0 (patch)
tree60a825635a24cf2c3e2dfd759126aab7dd330cf2 /libdrm/Makefile.am
parent604759d4a78efcef0abdb40bfc215526cdcf1122 (diff)
intel: Protect bufmgr objects with a pthread mutex.
We want to be able to use the bufmgr from multiple threads for GL, and thus we need to protect the internal structures. The pthread-stubs package is used so that programs not linked against pthreads get weak symbols to stubs and don't eat most of the cost.
Diffstat (limited to 'libdrm/Makefile.am')
-rw-r--r--libdrm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdrm/Makefile.am b/libdrm/Makefile.am
index f82d1917..543b2786 100644
--- a/libdrm/Makefile.am
+++ b/libdrm/Makefile.am
@@ -27,6 +27,7 @@ libdrm_la_LDFLAGS = -version-number 2:3:0 -no-undefined
AM_CFLAGS = -I$(top_srcdir)/shared-core
libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c \
libdrm_lists.h
+libdrm_la_LIBADD = intel/libdrm_intel.la @PTHREADSTUBS_LIBS@
libdrmincludedir = ${includedir}
libdrminclude_HEADERS = xf86drm.h