summaryrefslogtreecommitdiff
path: root/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2011-12-20 13:06:16 -0800
committerEric Anholt <eric@anholt.net>2011-12-29 16:43:36 -0800
commit71066abe1e32d906f65141c34ecfd9ffbf89ebde (patch)
tree597e797c9a7a1155154a598c8f34f58b24f037e0 /intel/Makefile.am
parentbbdda928d3c0fa2e5b38adc4c3f7763f957b5207 (diff)
intel: Get intel_decode.c minimally building.
My plan is to use this drm_intel_dump_batchbuffer() interface for the current GPU tools, and the current Mesa batch dumping usage, while eventually building more interesting interfaces for other uses. Warnings are currently suppressed by using a helper lib with CFLAGS set manually, because the code is totally not ready for libdrm's warnings setup. Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch> Acked-by: Eugeni Dodonov <eugeni@dodonov.net>
Diffstat (limited to 'intel/Makefile.am')
-rw-r--r--intel/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/intel/Makefile.am b/intel/Makefile.am
index 7a44aaf9..1af0187d 100644
--- a/intel/Makefile.am
+++ b/intel/Makefile.am
@@ -33,7 +33,20 @@ AM_CFLAGS = \
libdrm_intel_la_LTLIBRARIES = libdrm_intel.la
libdrm_intel_ladir = $(libdir)
libdrm_intel_la_LDFLAGS = -version-number 1:0:0 -no-undefined
-libdrm_intel_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@ @PCIACCESS_LIBS@ @CLOCK_LIB@
+libdrm_intel_la_LIBADD = ../libdrm.la \
+ @PTHREADSTUBS_LIBS@ \
+ @PCIACCESS_LIBS@ \
+ @CLOCK_LIB@ \
+ libintel_decode.la
+
+
+noinst_LTLIBRARIES = libintel_decode.la
+
+libintel_decode_la_SOURCES = intel_decode.c
+libintel_decode_la_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intel \
+ -std=c99
libdrm_intel_la_SOURCES = \
intel_bufmgr.c \
@@ -44,6 +57,8 @@ libdrm_intel_la_SOURCES = \
mm.c \
mm.h
+intel_bufmgr_gem_o_CFLAGS = $(AM_CFLAGS) -c99
+
libdrm_intelincludedir = ${includedir}/libdrm
libdrm_intelinclude_HEADERS = intel_bufmgr.h \
intel_debug.h