summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Clark <rob@ti.com>2012-03-28 14:39:43 -0500
committerDaniel Vetter <daniel.vetter@ffwll.ch>2012-03-28 23:00:14 +0200
commitef1b958cc831df3d33a366d1db2db2c88187229e (patch)
tree2b681262f81ffd3251f532b33561436006d3e5bc /configure.ac
parent617213357e94299a5e9a3cb1342de55de949d156 (diff)
omap: add omapdrm support
This adds libdrm_omap helper layer (as used by xf86-video-omap, omapdrmtest, etc). Signed-off-by: Rob Clark <rob@ti.com> Reviewed-by: Alex Deucher <alexander.deucher@amd.com> [danvet: pushed for Rob, he doesn't yet have commit access.] Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff2c8401..921dcbd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,10 @@ AC_ARG_ENABLE(nouveau-experimental-api,
[Enable support for nouveau's experimental API (default: disabled)]),
[NOUVEAU=$enableval], [NOUVEAU=no])
+AC_ARG_ENABLE(omap-experimental-api,
+ AS_HELP_STRING([--enable-omap-experimental-api],
+ [Enable support for OMAP's experimental API (default: disabled)]),
+ [OMAP=$enableval], [OMAP=no])
dnl ===========================================================================
dnl check compiler flags
@@ -182,6 +186,11 @@ if test "x$NOUVEAU" = xyes; then
AC_DEFINE(HAVE_NOUVEAU, 1, [Have nouveau (nvidia) support])
fi
+AM_CONDITIONAL(HAVE_OMAP, [test "x$OMAP" = xyes])
+if test "x$OMAP" = xyes; then
+ AC_DEFINE(HAVE_OMAP, 1, [Have OMAP support])
+fi
+
PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
if test "x$HAVE_CAIRO" = xyes; then
AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
@@ -291,6 +300,8 @@ AC_CONFIG_FILES([
radeon/libdrm_radeon.pc
nouveau/Makefile
nouveau/libdrm_nouveau.pc
+ omap/Makefile
+ omap/libdrm_omap.pc
tests/Makefile
tests/modeprint/Makefile
tests/modetest/Makefile
@@ -310,4 +321,5 @@ echo " Intel API $INTEL"
echo " vmwgfx API $VMWGFX"
echo " Radeon API $RADEON"
echo " Nouveau API $NOUVEAU"
+echo " OMAP API $OMAP"
echo ""